phpBB

Development Wiki

Difference between revisions of "PhpBB4/Requirements"

From phpBB Development Wiki

(Software Requirements)
(Add table)
 
Line 3: Line 3:
  
 
* '''PHP >= 5.3.0''' thus SPL is always available.
 
* '''PHP >= 5.3.0''' thus SPL is always available.
 +
 +
=== Web Server Support ===
 +
{|
 +
|-
 +
!rowspan="2"|Name
 +
!rowspan="2"|Branch
 +
!colspan="4"|Platforms
 +
!colspan="3"|PHP Interface
 +
|-
 +
! Linux
 +
! Windows
 +
! Mac OS X
 +
! BSD
 +
! SAPI
 +
! CGI
 +
! FastCGI
 +
|-
 +
|rowspan="3" style="background-color: rgb(144, 255, 144);"| Apache [http://httpd.apache.org/]
 +
|style="background-color: rgb(144, 255, 144);"| 2.2
 +
|rowspan="3"| Yes
 +
|rowspan="2"| Yes
 +
|rowspan="3"| Yes
 +
|rowspan="3"| Yes
 +
|rowspan="3"| Yes
 +
|rowspan="3"| Yes
 +
|rowspan="2"| Yes
 +
|-
 +
|style="background-color: rgb(144, 255, 144);"| 2.0
 +
|-
 +
| 1.3
 +
| No
 +
| No
 +
|-
 +
|rowspan="2" style="background-color: rgb(144, 255, 144);"| IIS
 +
|style="background-color: rgb(144, 255, 144);"| 7
 +
|rowspan="2"| No
 +
|rowspan="2"| Yes
 +
|rowspan="2"| No
 +
|rowspan="2"| No
 +
|rowspan="2"| No
 +
|rowspan="2"| Yes
 +
|rowspan="2"| Yes
 +
|-
 +
| 6
 +
|-
 +
|style="background-color: rgb(144, 255, 144);"| lighttpd [http://www.lighttpd.net/]
 +
|style="background-color: rgb(144, 255, 144);"| 1.4
 +
| Yes
 +
| Yes (via Cygwin)
 +
| Yes
 +
| Yes
 +
| No
 +
| No
 +
| Yes
 +
|-
 +
|style="background-color: rgb(144, 255, 144);"| nginx [http://nginx.org/]
 +
|style="background-color: rgb(144, 255, 144);"| 0.7
 +
| Yes
 +
| Yes
 +
| Yes
 +
| Yes
 +
| No
 +
| No
 +
| Yes
 +
|-
 +
| Cherokee [http://www.cherokee-project.com/]
 +
| 0.99
 +
| Yes
 +
| Yes
 +
| Yes
 +
| Yes
 +
| No
 +
| Yes
 +
| Yes
 +
|-
 +
| LiteSpeed [http://www.litespeedtech.com/overview.html]
 +
| 4.0
 +
| Yes
 +
| No
 +
| Yes
 +
| Yes
 +
| No
 +
| Yes
 +
| Yes
 +
|-
 +
|}

Latest revision as of 02:20, 20 December 2009

Software Requirements

These requirements will have to be met by the server that shall run phpBB4.

  • PHP >= 5.3.0 thus SPL is always available.

Web Server Support

Name Branch Platforms PHP Interface
Linux Windows Mac OS X BSD SAPI CGI FastCGI
Apache [1] 2.2 Yes Yes Yes Yes Yes Yes Yes
2.0
1.3 No No
IIS 7 No Yes No No No Yes Yes
6
lighttpd [2] 1.4 Yes Yes (via Cygwin) Yes Yes No No Yes
nginx [3] 0.7 Yes Yes Yes Yes No No Yes
Cherokee [4] 0.99 Yes Yes Yes Yes No Yes Yes
LiteSpeed [5] 4.0 Yes No Yes Yes No Yes Yes