phpBB

Development Wiki

PhpBB4/Requirements

From phpBB Development Wiki

Software Requirements

These requirements will have to be met by the server that shall run phpBB4.

  • PHP >= 5.3.0 thus SPL is always available.

Web Server Support

Name Branch Platforms PHP Interface
Linux Windows Mac OS X BSD SAPI CGI FastCGI
Apache [1] 2.2 Yes Yes Yes Yes Yes Yes Yes
2.0
1.3 No No
IIS 7 No Yes No No No Yes Yes
6
lighttpd [2] 1.4 Yes Yes (via Cygwin) Yes Yes No No Yes
nginx [3] 0.7 Yes Yes Yes Yes No No Yes
Cherokee [4] 0.99 Yes Yes Yes Yes No Yes Yes
LiteSpeed [5] 4.0 Yes No Yes Yes No Yes Yes