phpBB

Development Wiki

JQuery Update Policy

From phpBB Development Wiki

Policy

We may update jQuery to the latest stable version at any time. This includes patch releases of phpBB. In other words, between phpBB 3.1.x and 3.1.x+1 we can update jQuery from 1.a.b to 1.c.d for any values of a, b, c and d.

We may not update jQuery if the version we include has no outstanding security problems, and there are compatibility issues with newer versions.

We will update jQuery if there is a security problem found in the version that we include. If necessary we will release a patch release (-PL) for such an update.

jQuery updates will be going through the usual channels, namely via a bug/improvement ticket on the issue tracker and a pull request.

Rationale

jQuery generally appears to maintain compatibility between releases. Historically there was not much breakage going from version 1.x to 1.x+1.

There are also plugins available to restore functionality of old versions on newer versions.